<!doctype html> <!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]--> <!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]--> <!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]--> <!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]--> <!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]--><head><meta name="google-site-verification" content="yyXg1xyAAaD8ut5aTwaVQ1alb0LWWBXT6-yo1e82ELs" />  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-136451140-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-136451140-1');</script> <script data-ad-client="ca-pub-8936073316663999" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="https://newsheater.com/xmlrpc.php" /><title>Is Hecla Mining Company (HL) a Keeper? &#8211; News Heater</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3Aregular%2C600%7CRoboto%3A700%2C500%2C500%2C700%2C&display=swap" /><link rel="stylesheet" href="https://newsheater.com/wp-content/cache/min/1/0e4cef34f9125406b2a9a90370b30fb7.css" data-minify="1" /><meta property="og:type" content="article"><meta property="og:title" content="Is Hecla Mining Company (HL) a Keeper?"><meta property="og:site_name" content="News Heater"><meta property="og:description" content="Hecla Mining Company (NYSE:HL) went down by -10.98% from its latest closing price compared to the recent 1-year high of"><meta property="og:url" content="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/"><meta property="og:locale" content="en_US"><meta property="og:image" content="https://newsheater.com/wp-content/uploads/2020/01/Image-128.png"><meta property="og:image:height" content="425"><meta property="og:image:width" content="640"><meta property="article:published_time" content="2021-01-11T10:12:00+00:00"><meta property="article:modified_time" content="2021-01-11T10:12:00+00:00"><meta property="article:section" content="Trending"><meta property="article:tag" content="Hecla Mining Company"><meta property="article:tag" content="HL"><meta property="article:tag" content="HL stock"><meta property="article:tag" content="NYSE:HL"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Is Hecla Mining Company (HL) a Keeper?"><meta name="twitter:description" content="Hecla Mining Company (NYSE:HL) went down by -10.98% from its latest closing price compared to the recent 1-year high of"><meta name="twitter:url" content="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/"><meta name="twitter:site" content=""><meta name="twitter:image:src" content="https://newsheater.com/wp-content/uploads/2020/01/Image-128.png"><meta name="twitter:image:width" content="640"><meta name="twitter:image:height" content="425"> <script type="text/javascript">var jnews_ajax_url = '/?ajax-request=jnews'</script> <link rel='dns-prefetch' href='//www.getpushmonkey.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//newsheater.com' /><link rel="alternate" type="application/rss+xml" title="News Heater &raquo; Feed" href="https://newsheater.com/feed/" /><link rel="alternate" type="application/rss+xml" title="News Heater &raquo; Comments Feed" href="https://newsheater.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="News Heater &raquo; Is Hecla Mining Company (HL) a Keeper? Comments Feed" href="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/feed/" /> <script>function cpLoadCSS(e,t,n){"use strict";var i=window.document.createElement("link"),o=t||window.document.getElementsByTagName("script")[0];return i.rel="stylesheet",i.href=e,i.media="only x",o.parentNode.insertBefore(i,o),setTimeout(function(){i.media=n||"all"}),i}</script><style>.cp-popup-container .cpro-overlay,.cp-popup-container .cp-popup-wrapper{opacity:0;visibility:hidden;display:none}</style><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style> <script>document.addEventListener('DOMContentLoaded', function(event) {  if( typeof cpLoadCSS !== 'undefined' ) { cpLoadCSS('https://newsheater.com/wp-content/plugins/convertpro/assets/modules/css/cp-popup.min.css?ver=1.5.5', 0, 'all'); } });</script>  <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script> <script   type='text/javascript' src='https://www.getpushmonkey.com/sdk/config-7QUYF0GA4E51B8XWN.js?dialog_color=%23CEDE9B&#038;button_color=%2399CC56&#038;subdomain_forced=0&#038;ver=5.6' id='push_monkey_sdk-js' defer></script> <link rel="https://api.w.org/" href="https://newsheater.com/wp-json/" /><link rel="alternate" type="application/json" href="https://newsheater.com/wp-json/wp/v2/posts/238879" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://newsheater.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://newsheater.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.6" /><link rel="canonical" href="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/" /><link rel='shortlink' href='https://newsheater.com/?p=238879' /><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><link rel="amphtml" href="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/amp/"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/newsheater.com\/#organization","url":"https:\/\/newsheater.com\/","name":"News Heater","logo":{"@type":"ImageObject","url":"https:\/\/newsheater.com\/wp-content\/uploads\/2021\/01\/newsheater-logo-1.png"},"sameAs":["https:\/\/www.facebook.com\/jegtheme\/","https:\/\/twitter.com\/jegtheme","https:\/\/plus.google.com\/+Jegtheme","https:\/\/www.linkedin.com\/"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/newsheater.com\/#website","url":"https:\/\/newsheater.com\/","name":"News Heater","potentialAction":{"@type":"SearchAction","target":"https:\/\/newsheater.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://newsheater.com/wp-content/uploads/2020/08/cropped-newshetaer-fav-icon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://newsheater.com/wp-content/uploads/2020/08/cropped-newshetaer-fav-icon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://newsheater.com/wp-content/uploads/2020/08/cropped-newshetaer-fav-icon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://newsheater.com/wp-content/uploads/2020/08/cropped-newshetaer-fav-icon-1-270x270.png" /><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail .jeg_thumb,.thumbnail-container.no_thumbnail{display:none!important}.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_pl_sm.no_thumbnail .jeg_postblock_content{margin-left:0}.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content{margin-top:0}.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content{position:relative}.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa{color:#212121!important}</style><style type="text/css" id="wp-custom-css">.footer-post-form{display:none}.single-post .footer-post-form{display:block}.footer-post-form{background:url(https://newsheater.com/wp-content/uploads/2021/01/stock-telegraph-bg.jpg) no-repeat center center;padding:20px;color:#fff;text-align:center;display:none;background-size:cover;position:relative;margin-top:15px}.footer-post-form::before{content:'';background:rgba(0,0,0,.5);position:absolute;left:0;width:100%;height:100%;top:0;right:0;bottom:0}.footer-post-form-inner{position:relative;z-index:1}.footer-post-form h2{color:#fff;font-weight:700;margin:10px 0 0 0}.footer-post-form .submit{background:#33D7AB;width:100%!important;margin-top:10px;font-size:20px;text-transform:uppercase;height:50px}.footer-post-form .submit:hover{background:#21deab!important}.footer-post-form .text{height:50px;border:none;font-size:14px;padding:10px 20px;width:100%!important}.footer-post-form p{color:#fff!important}</style><style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1517813231908{padding-top:60px!important;padding-bottom:30px!important;background-color:#191818!important;background-position:center;background-repeat:no-repeat;background-size:cover!important}.vc_custom_1610224066737{margin-bottom:0px!important}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-238879 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal wpb-js-composer js-comp-ver-6.4.2 vc_responsive"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_midbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://newsheater.com/" style="padding: 0px 0px 0px 5px;"> <img class='jeg_logo_img' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" alt="News Heater"data-light-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-light-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" data-dark-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-dark-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" data-lazy-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png"><noscript><img class='jeg_logo_img' src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" alt="News Heater"data-light-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-light-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" data-dark-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-dark-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x"></noscript> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_grow"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads"><div class='ads-wrapper '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_MT6DEwymO9{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_MT6DEwymO9{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_MT6DEwymO9{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_MT6DEwymO9" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></div></div></div></div></div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="animate"><li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-62 bgnav" data-item-row="default" ><a href="https://newsheater.com/">Home</a></li><li id="menu-item-236584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-236584 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/stock-ideas/">Stock Ideas</a><ul class="sub-menu"><li id="menu-item-236585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236585 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/morning-brief/">Morning Brief</a></li><li id="menu-item-236586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236586 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/analyst-rating/">Analyst Insight</a></li><li id="menu-item-236587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236587 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/equity-research/">Equity Research</a></li></ul></li><li id="menu-item-236588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-236588 bgnav" data-item-row="default" ><a href="https://newsheater.com/about-newsheater/">About Newsheater</a><ul class="sub-menu"><li id="menu-item-236590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236590 bgnav" data-item-row="default" ><a href="https://newsheater.com/authors/">Authors</a></li><li id="menu-item-236589" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236589 bgnav" data-item-row="default" ><a href="https://newsheater.com/contact-us/">Contact Us</a></li></ul></li><li id="menu-item-236592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236592 bgnav" data-item-row="default" ><a href="https://newsheater.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_nav_search"><div class="jeg_search_wrapper jeg_search_no_expand rounded"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://newsheater.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div></div></div><div class="jeg_header_sticky"><div class="sticky_blankspace"></div><div class="jeg_header normal"><div class="jeg_container"><div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_4" data-animation="animate"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-62 bgnav" data-item-row="default" ><a href="https://newsheater.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-236584 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/stock-ideas/">Stock Ideas</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236585 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/morning-brief/">Morning Brief</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236586 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/analyst-rating/">Analyst Insight</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236587 bgnav" data-item-row="default" ><a href="https://newsheater.com/category/equity-research/">Equity Research</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-236588 bgnav" data-item-row="default" ><a href="https://newsheater.com/about-newsheater/">About Newsheater</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236590 bgnav" data-item-row="default" ><a href="https://newsheater.com/authors/">Authors</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236589 bgnav" data-item-row="default" ><a href="https://newsheater.com/contact-us/">Contact Us</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236592 bgnav" data-item-row="default" ><a href="https://newsheater.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"></div></div></div></div></div></div></div></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="scroll"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://newsheater.com/"> News Heater </a></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://newsheater.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 60px;"></div></div><div class="post-wrapper"><div class="post-wrap" ><div class="jeg_main "><div class="jeg_container"><div class="jeg_content jeg_singlepage"><div class="container"><div class="jeg_ad jeg_article jnews_article_top_ads"><div class='ads-wrapper '></div></div><div class="row"><div class="jeg_main_content col-md-8"><div class="jeg_inner_content"><div class="jeg_breadcrumbs jeg_breadcrumb_container"><div id="breadcrumbs"><span class=""> <a href="https://newsheater.com">Home</a> </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link"> <a href="https://newsheater.com/category/trending/">Trending</a> </span></div></div><div class="entry-header"><h1 class="jeg_post_title">Is Hecla Mining Company (HL) a Keeper?</h1><div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1"><div class="meta_left"><div class="jeg_meta_author"> <span class="meta_text">by</span> <a href="https://newsheater.com/author/denise-gardner/">Denise Gardner</a></div><div class="jeg_meta_date"> <a href="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/">January 11, 2021</a></div><div class="jeg_meta_category"> <span><span class="meta_text">in</span> <a href="https://newsheater.com/category/trending/" rel="category tag">Trending</a> </span></div></div><div class="meta_right"><div class="jeg_meta_comment"><a href="https://newsheater.com/2021/01/is-hecla-mining-company-hl-a-keeper/#comments"><i class="fa fa-comment-o"></i> 0</a></div></div></div></div></div><div class="jeg_featured featured_image"><a href="https://newsheater.com/wp-content/uploads/2020/01/Image-128.png"><div class="thumbnail-container animate-lazy" style="padding-bottom:58.594%"><img width="640" height="375" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-750x375 size-jnews-750x375 lazyload wp-post-image" alt="" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-128-640x375.png" data-srcset="" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_share_top_container"><div class="jeg_share_button clearfix"><div class="jeg_share_stats"></div><div class="jeg_sharelist"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F+via+%40jegtheme&url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><div class="share-secondary"> <a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F&title=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://plus.google.com/share?url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-google-plus removed "><i class="fa fa-google-plus"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F&media=https://newsheater.com/wp-content/uploads/2020/01/Image-128.png&description=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a></div> <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a></div></div></div><div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_hKb2cB8tdf{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_hKb2cB8tdf{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_hKb2cB8tdf{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_hKb2cB8tdf" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><div class="entry-content no-share"><div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome"><div class="jeg_share_float_container"></div></div><div class="content-inner "><p><b>Hecla Mining Company (NYSE:HL)</b> went down by -10.98% from its latest closing price compared to the recent 1-year high of $7.06. The company’s stock price has collected -6.17% of loss in the last five trading sessions. <a href='http://www.wsj.com/articles/PR-CO-20201210-905638'>Press Release</a> reported on 12/10/20 that Hecla Enters Into First Nation Cooperation Agreement</p><h3 style="text-align: center;"><span style="color: #0000ff;"><a style="color: #0000ff;" href="#" class="manual_trigger_236629"> Get the hottest stocks to trade every day before the market opens 100% free. Click here now. </a></span></h3><h2>Is It Worth Investing in Hecla Mining Company (NYSE :HL) Right Now?</h2><p> Plus, the 36-month beta value for HL is at 2.20.</p><div class='jnews_inline_related_post_wrapper right'><div class='jnews_inline_related_post'><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_238879_0_5ffd69e1a15bd " data-unique="jnews_module_238879_0_5ffd69e1a15bd"><div class="jeg_block_heading jeg_block_heading_7 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related articles</span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-92-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-92-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-92-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/">Daily High to Daily Low: Is It Safe to Buy Sierra Metals Inc. (SMTS)?</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/" ><i class="fa fa-clock-o"></i> January 12, 2021</a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-88-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-88-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-88-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/">Tyme Technologies Inc. (TYME): Skating on Thin Ice? We Know the Answer</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/" ><i class="fa fa-clock-o"></i> January 12, 2021</a></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_238879_0_5ffd69e1a15bd = {"header_icon":"","first_title":"Related articles","second_title":"","url":"","header_type":"heading_7","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"2","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":238879,"include_category":"126","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","ata_snippets_category":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"2","pagination_scroll_limit":0,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_21"};</script> </div></div></div><p> HL currently public float of 521.45M and currently shorts hold a 2.37% ratio of that float. Today, the average trading volume of HL was 7.93M shares.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_ads "><div class='ads-wrapper align-center '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_vrpIUXb815{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_vrpIUXb815{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_vrpIUXb815{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_vrpIUXb815" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><h2>HL’s Market Performance</h2><p>HL stocks went down by -6.17% for the week, with a monthly jump of 14.29% and a quarterly performance of 16.92%, while its annual performance rate touched 98.05%. The volatility ratio for the week stands at 6.24% while the volatility levels for the past 30 days are set at 5.71% for Hecla Mining Company. The simple moving average for the period of the last 20 days is -0.01% for HL stocks with a simple moving average of 36.51% for the last 200 days.</p><h3>Analysts’ Opinion of HL</h3><p>Many brokerage firms have already submitted their reports for HL stocks, with ROTH Capital repeating the rating for HL by listing it as a “Buy.” The predicted price for HL in the upcoming period, according to ROTH Capital is $6 based on the research report published on October 27th of the previous year 2020.</p><p> RBC Capital Mkts gave a rating of “Sector Perform” to HL, setting the target price at $4.50 in the report published on July 17th of the previous year.</p><h3>HL Trading at 11.07% from the 50-Day Moving Average</h3><p>After a stumble in the market that brought HL to its low price for the period of the last 52 weeks, the company was unable to rebound, for now settling with -13.94% of loss for the given period.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads "><div class='ads-wrapper align-center '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_MNbkJ58C6j{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_MNbkJ58C6j{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_MNbkJ58C6j{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_MNbkJ58C6j" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><p> Volatility was left at 5.71%, however, over the last 30 days, the volatility rate increased by 6.24%, as shares surge +20.16% for the moving average over the last 20 days. Over the last 50 days, in opposition, the stock is trading +19.69% upper at present.</p><p> During the last 5 trading sessions, HL fell by -6.17%, which changed the moving average for the period of 200-days by +167.84% in comparison to the 20-day moving average, which settled at $6.13. In addition, Hecla Mining Company saw -6.17% in overturn over a single year, with a tendency to cut further losses.</p><h3>Insider Trading</h3><p>Reports are indicating that there were more than several insider trading activities at HL starting from Rogers Terry V, who sale 35,000 shares at the price of $5.96 back on Aug 13. After this action, Rogers Terry V now owns 70,013 shares of Hecla Mining Company, valued at $208,495 using the latest closing price.</p><p>Sienko David C, the VP &#038; General Counsel of Hecla Mining Company, sale 75,000 shares at $6.01 during a trade that took place back on Aug 13, which means that Sienko David C is holding 847,004 shares at $450,450 based on the most recent closing price.</p><h3>Stock Fundamentals for HL</h3><p>Current profitability levels for the company are sitting at:</p><div class="jeg_ad jeg_ad_article jnews_content_inline_3_ads "><div class='ads-wrapper align-center '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_sYwH2uTLmG{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_sYwH2uTLmG{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_sYwH2uTLmG{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_sYwH2uTLmG" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><ul><li>-7.30 for the present operating margin</li><li>+1.03 for the gross margin</li></ul><p> The net margin for Hecla Mining Company stands at -14.76. The total capital return value is set at -2.21, while invested capital returns managed to touch -4.48. Equity return is now at value -1.60, with -1.00 for asset returns.</p><p> Based on Hecla Mining Company (HL), the company’s capital structure generated 31.54 points at debt to equity in total, while total debt to capital is 23.98. Total debt to assets is 20.24, with long-term debt to equity ratio resting at 30.89. Finally, the long-term debt to capital ratio is 23.48.</p><h3 style="text-align: center;"><span style="color: #0000ff;"><a style="color: #0000ff;" href="#" class="manual_trigger_236629"> Get the hottest stocks to trade every day before the market opens 100% free. Click here now. </a></span></h3><p> When we switch over and look at the enterprise to sales, we see a ratio of 3.16, with the company’s debt to enterprise value settled at 0.25. The receivables turnover for the company is 21.00 and the total asset turnover is 0.25. The liquidity ratio also appears to be rather interesting for investors as it stands at 1.53.</p> <span class="cp-load-after-post"></span><div class="footer-post-form"><div class="footer-post-form-inner"><h2>Get The Best Stocks To Trade Every Day!</h2><p>Join now to get the NewsHeater.com pre-market morning brief 100% free</p><form method="post" class="af-form-wrapper" accept-charset="UTF-8" action="https://www.aweber.com/scripts/addlead.pl" ><div style="display: none;"> <input type="hidden" name="meta_web_form_id" value="317242835" /> <input type="hidden" name="meta_split_id" value="" /> <input type="hidden" name="listname" value="awlist5641516" /> <input type="hidden" name="redirect" value="https://offers.afteroffers.com/show_offers/568-RiAQXxc-1" id="redirect_18d71052ef474f7c0b4b401915053068" /> <input type="hidden" name="meta_adtracking" value="My Web Form" /> <input type="hidden" name="meta_message" value="1" /> <input type="hidden" name="meta_required" value="email" /> <input type="hidden" name="meta_forward_vars" value="1" /> <input type="hidden" name="meta_tooltip" value="" /></div> <input class="text" id="awf_field-109620329" type="text" name="email" placeholder="Enter your email here" value="" tabindex="500" onfocus=" if (this.value == '') { this.value = ''; }" onblur="if (this.value == '') { this.value='';} " /> <input name="submit" class="submit" type="submit" value="Submit" tabindex="501" /><div style="display: none;"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://forms.aweber.com/form/displays.htm?id=zIzsTCxMHMys" /><noscript><img src="https://forms.aweber.com/form/displays.htm?id=zIzsTCxMHMys" alt="" /></noscript></div></form> <script type="text/javascript">// Special handling for in-app browsers that don't always support new windows
(function() {
    function browserSupportsNewWindows(userAgent) {
        var rules = [
            'FBIOS',
            'Twitter for iPhone',
            'WebView',
            '(iPhone|iPod|iPad)(?!.*Safari/)',
            'Android.*(wv|.0.0.0)'
        ];
        var pattern = new RegExp('(' + rules.join('|') + ')', 'ig');
        return !pattern.test(userAgent);
    }

    if (!browserSupportsNewWindows(navigator.userAgent || navigator.vendor || window.opera)) {
        document.getElementById('af-form-317242835').parentElement.removeAttribute('target');
    }
})();</script><script type="text/javascript">(function() {
        var IE = /*@cc_on!@*/false;
        if (!IE) { return; }
        if (document.compatMode && document.compatMode == 'BackCompat') {
            if (document.getElementById("af-form-317242835")) {
                document.getElementById("af-form-317242835").className = 'af-form af-quirksMode';
            }
            if (document.getElementById("af-body-317242835")) {
                document.getElementById("af-body-317242835").className = "af-body inline af-quirksMode";
            }
            if (document.getElementById("af-header-317242835")) {
                document.getElementById("af-header-317242835").className = "af-header af-quirksMode";
            }
            if (document.getElementById("af-footer-317242835")) {
                document.getElementById("af-footer-317242835").className = "af-footer af-quirksMode";
            }
        }
    })();</script> </div></div><div class="jeg_post_tags"><span>Tags:</span> <a href="https://newsheater.com/tag/hecla-mining-company/" rel="tag">Hecla Mining Company</a><a href="https://newsheater.com/tag/hl/" rel="tag">HL</a><a href="https://newsheater.com/tag/hl-stock/" rel="tag">HL stock</a><a href="https://newsheater.com/tag/nysehl/" rel="tag">NYSE:HL</a></div></div></div><div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix"><div class="jeg_sharelist"> <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share<span class="count">76</span></span></a><a href="https://twitter.com/intent/tweet?text=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F+via+%40jegtheme&url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet<span class="count">47</span></span></a><div class="share-secondary"> <a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F&title=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://plus.google.com/share?url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" rel='nofollow' class="jeg_btn-google-plus removed "><i class="fa fa-google-plus"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F&media=https://newsheater.com/wp-content/uploads/2020/01/Image-128.png&description=Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F" rel='nofollow' class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a></div> <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a></div></div></div><div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_bQmUAWLrDY{width:728px!important;height:90px!important}@media (max-width:1199px){.adsslot_bQmUAWLrDY{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_bQmUAWLrDY{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_bQmUAWLrDY" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post"> <a href="https://newsheater.com/2021/01/why-asia-pacific-wire-cable-corporation-limited-apwcs-most-recent-report-reveals-some-hints-about-its-future/" class="post prev-post"> <span class="caption">Previous Post</span><h3 class="post-title">Why Asia Pacific Wire &#038; Cable Corporation Limited (APWC)’s Most Recent Report Reveals Some Hints About Its Future</h3> </a> <a href="https://newsheater.com/2021/01/orbital-energy-group-inc-oeg-skating-on-thin-ice-we-know-the-answer-2/" class="post next-post"> <span class="caption">Next Post</span><h3 class="post-title">Orbital Energy Group Inc. (OEG): Skating on Thin Ice? We Know the Answer</h3> </a></div></div><div class="jnews_author_box_container "></div><div class="jnews_related_post_container"><div class="jeg_postblock_3 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_238879_1_5ffd69e1b1f5d " data-unique="jnews_module_238879_1_5ffd69e1b1f5d"><div class="jeg_block_heading jeg_block_heading_7 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_posts jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_2 format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" sizes="(max-width: 350px) 100vw, 350px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-92-350x250.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-92-350x250.png 350w, https://newsheater.com/wp-content/uploads/2020/01/Image-92-120x86.png 120w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/">Daily High to Daily Low: Is It Safe to Buy Sierra Metals Inc. (SMTS)?</a></h3><div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://newsheater.com/author/ethane-eddington/">Ethane Eddington</a></div><div class="jeg_meta_date"><a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/"><i class="fa fa-clock-o"></i> January 12, 2021</a></div><div class="jeg_meta_comment"><a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div><div class="jeg_post_excerpt"><p>Sierra Metals Inc. (AMEX:SMTS) went up by 14.46% from its latest closing price compared to the recent 1-year high of...</p></div></div></article><article class="jeg_post jeg_pl_md_2 format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="" sizes="(max-width: 350px) 100vw, 350px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-88-350x250.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-88-350x250.png 350w, https://newsheater.com/wp-content/uploads/2020/01/Image-88-120x86.png 120w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"> <a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/">Tyme Technologies Inc. (TYME): Skating on Thin Ice? We Know the Answer</a></h3><div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://newsheater.com/author/denise-gardner/">Denise Gardner</a></div><div class="jeg_meta_date"><a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/"><i class="fa fa-clock-o"></i> January 12, 2021</a></div><div class="jeg_meta_comment"><a href="https://newsheater.com/2021/01/tyme-technologies-inc-tyme-skating-on-thin-ice-we-know-the-answer/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div><div class="jeg_post_excerpt"><p>Tyme Technologies Inc. (NASDAQ:TYME) went up by 14.67% from its latest closing price compared to the recent 1-year high of...</p></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div><div class="jeg_block_loadmore "> <a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a></div></div> <script>var jnews_module_238879_1_5ffd69e1b1f5d = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_7","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"2","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":238879,"include_category":"126","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","ata_snippets_category":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"2","pagination_scroll_limit":3,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_3"};</script> </div></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/01/is-hecla-mining-company-hl-a-keeper/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://newsheater.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='238879' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></div><div class="jeg_sidebar jeg_sticky_sidebar col-md-4"><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-1"><div class='jeg_ad jeg_ad_module jnews_module_238879_2_5ffd69e1bceb4 '><div class='ads-wrapper'><div class=""><style type='text/css' scoped>.adsslot_FYVJ1v6yAa{width:300px!important;height:250px!important}@media (max-width:1199px){.adsslot_FYVJ1v6yAa{width:300px!important;height:250px!important}}@media (max-width:767px){.adsslot_FYVJ1v6yAa{width:300px!important;height:250px!important}}</style><ins class="adsbygoogle adsslot_FYVJ1v6yAa" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="4579150242"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></div><div class="widget widget_jnews_tab_post" id="jnews_tab_post-1"><div class="jeg_tabpost_widget"><ul class="jeg_tabpost_nav"><li data-tab-content="jeg_tabpost_1" class="active">Trending</li><li data-tab-content="jeg_tabpost_2">Comments</li><li data-tab-content="jeg_tabpost_3">Latest</li></ul><div class="jeg_tabpost_content"><div class="jeg_tabpost_item active" id="jeg_tabpost_1"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2020/11/business-model-helped-nio-stock-add-11-times-to-its-value-this-year/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-68-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-68-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-68-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2020/11/business-model-helped-nio-stock-add-11-times-to-its-value-this-year/">Business Model Helped NIO Stock Add 11 Times To Its Value This Year</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> November 13, 2020</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/why-applied-dna-sciences-inc-apdns-most-recent-report-reveals-some-hints-about-its-future/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-64-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-64-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-64-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/why-applied-dna-sciences-inc-apdns-most-recent-report-reveals-some-hints-about-its-future/">Why Applied DNA Sciences Inc. (APDN)’s Most Recent Report Reveals Some Hints About Its Future</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> January 11, 2021</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/we-analyzed-the-future-direction-of-transenterix-inc-trxc-here-is-what-we-found/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-90-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-90-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-90-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/we-analyzed-the-future-direction-of-transenterix-inc-trxc-here-is-what-we-found/">We Analyzed the Future Direction of TransEnterix Inc. (TRXC), Here is What We Found</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> January 11, 2021</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/the-chart-for-tesla-inc-tsla-is-flashing-mixed-signals/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-112-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-112-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-112-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/the-chart-for-tesla-inc-tsla-is-flashing-mixed-signals/">The Chart for Tesla Inc. (TSLA) Is Flashing Mixed Signals</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> January 11, 2021</div></div></div></div></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_2"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2020/08/4-stocks-to-watch-today/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-31-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-31-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-31-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2020/08/4-stocks-to-watch-today/">4 Stocks to Watch Today&#8230;</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 0</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2020/08/a-2-5g-picks-and-shovels-company-with-bullish-momentum/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-47-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-47-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-47-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2020/08/a-2-5g-picks-and-shovels-company-with-bullish-momentum/">A $2 5G Picks and Shovels Company with Bullish Momentum&#8230;</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 0</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2020/08/these-4-stocks-are-ready-to-move/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-4-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-4-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-4-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2020/08/these-4-stocks-are-ready-to-move/">These 4 Stocks are ready to move!</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 0</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2020/08/4-stocks-to-watch-on-tuesday/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-81-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-81-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-81-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2020/08/4-stocks-to-watch-on-tuesday/">4 Stocks to Watch on Tuesday&#8230;</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 0</div></div></div></div></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_3"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/looking-closely-at-the-growth-curve-for-lemonade-inc-lmnd/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-94-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-94-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-94-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/looking-closely-at-the-growth-curve-for-lemonade-inc-lmnd/">Looking Closely at the Growth Curve for Lemonade Inc. (LMND)</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-clock-o"></i> January 12, 2021</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/wall-street-pummels-orchard-therapeutics-plc-ortx-after-recent-earnings-report/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-93-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-93-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-93-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/wall-street-pummels-orchard-therapeutics-plc-ortx-after-recent-earnings-report/">Wall Street Pummels Orchard Therapeutics plc (ORTX) After Recent Earnings Report</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-clock-o"></i> January 12, 2021</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-92-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-92-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-92-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/daily-high-to-daily-low-is-it-safe-to-buy-sierra-metals-inc-smts/">Daily High to Daily Low: Is It Safe to Buy Sierra Metals Inc. (SMTS)?</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-clock-o"></i> January 12, 2021</div></div></div></div><div class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb"> <a href="https://newsheater.com/2021/01/we-analyzed-the-future-direction-of-myovant-sciences-ltd-myov-here-is-what-we-found-2/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="" sizes="(max-width: 120px) 100vw, 120px" data-src="https://newsheater.com/wp-content/uploads/2020/01/Image-91-120x86.png" data-srcset="https://newsheater.com/wp-content/uploads/2020/01/Image-91-120x86.png 120w, https://newsheater.com/wp-content/uploads/2020/01/Image-91-350x250.png 350w" data-sizes="auto" data-expand="700" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title"><a property="url" href="https://newsheater.com/2021/01/we-analyzed-the-future-direction-of-myovant-sciences-ltd-myov-here-is-what-we-found-2/">We Analyzed the Future Direction of Myovant Sciences Ltd. (MYOV), Here is What We Found</a></h3><div class="jeg_post_meta"><div class="jeg_meta_like"><i class="fa fa-clock-o"></i> January 12, 2021</div></div></div></div></div></div></div></div></div></div></div><div class="jeg_ad jeg_article jnews_article_bottom_ads"><div class='ads-wrapper '><div class="ads_google_ads"><style type='text/css' scoped>.adsslot_FaRyjNTGZn{width:970px!important;height:90px!important}@media (max-width:1199px){.adsslot_FaRyjNTGZn{width:468px!important;height:60px!important}}@media (max-width:767px){.adsslot_FaRyjNTGZn{width:320px!important;height:50px!important}}</style><ins class="adsbygoogle adsslot_FaRyjNTGZn" style="display:inline-block;" data-ad-client="ca-pub-8936073316663999" data-ad-slot="5018126456"></ins> <script async src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-238879 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal wpb-js-composer js-comp-ver-6.4.2 vc_responsive"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_custom"><div class="jeg_container"><div class="jeg_content"><div class="jeg_vc_content"><p><style type='text/css' scoped>.jeg_footer .jnews_5ffd69e204acf .widget h2,.jeg_footer .jnews_5ffd69e204acf.footer_light .jeg_footer_heading h3,.jnews_5ffd69e204acf.footer_dark .jeg_footer_heading h3{color:#fcbf46}.jeg_footer .jnews_5ffd69e204acf input[type="submit"],.jeg_footer .jnews_5ffd69e204acf .btn,.jeg_footer .jnews_5ffd69e204acf .button{background-color:#fcb11e}</style><div data-vc-full-width="true" data-vc-full-width-init="false" data-vc-parallax="1.5" style="background-repeat: no-repeat !important;background-position: center center !important"" class="row vc_row wpb_row vc_row-fluid vc_custom_1517813231908 vc_row-has-fill vc_row-has-border vc_general vc_parallax vc_parallax-content-moving jnews_5ffd69e204acf footer_dark"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-3"><div class="jeg_wrapper wpb_wrapper"><div class="jeg_about "> <a class="footer_logo" href="https://newsheater.com/"> <img class='lazyload' src="https://newsheater.com/wp-content/themes/jnews/assets/img/jeg-empty.png" data-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" alt="News Heater" data-light-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png" data-light-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater_logo-removebg-preview.png 2x" data-dark-src="https://newsheater.com/wp-content/uploads/2021/01/newsheater-logo-1.png" data-dark-srcset="https://newsheater.com/wp-content/uploads/2021/01/newsheater-logo-1.png 1x, https://newsheater.com/wp-content/uploads/2021/01/newsheater-logo-1.png 2x" data-pin-no-hover="true"> </a><p>News Heater is specialized on the investments in tech sphere. Its specialists are interested in stocks that have been undervalued by different reasons. They are trying to find them, count their potential and bring them to their clients.</p></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-3"><div class="jeg_wrapper wpb_wrapper"><div class="vc_wp_categories wpb_content_element"><div class="widget widget_categories"><h2 class="widgettitle">Categories</h2><ul><li class="cat-item cat-item-7376"><a href="https://newsheater.com/category/analyst-rating/">Analyst Insight</a></li><li class="cat-item cat-item-4"><a href="https://newsheater.com/category/business/" title="You can add some category description here.">Business</a></li><li class="cat-item cat-item-112"><a href="https://newsheater.com/category/companies/">Companies</a></li><li class="cat-item cat-item-5389"><a href="https://newsheater.com/category/equity-research/">Equity Research</a></li><li class="cat-item cat-item-120"><a href="https://newsheater.com/category/hot-stocks/">Hot Stocks</a></li><li class="cat-item cat-item-45"><a href="https://newsheater.com/category/morning-brief/">Morning Brief</a></li><li class="cat-item cat-item-25"><a href="https://newsheater.com/category/stock-ideas/">Stock Ideas</a></li><li class="cat-item cat-item-126"><a href="https://newsheater.com/category/trending/">Trending</a></li><li class="cat-item cat-item-1"><a href="https://newsheater.com/category/uncategorized/">Uncategorized</a></li></ul></div></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-3"><div class="jeg_wrapper wpb_wrapper"><div class="vc_wp_tagcloud wpb_content_element"><div class="widget widget_tag_cloud"><h2 class="widgettitle">Tags</h2><div class="tagcloud"><a href="https://newsheater.com/tag/att-inc/" class="tag-cloud-link tag-link-1329 tag-link-position-1" style="font-size: 8.5283018867925pt;" aria-label="AT&amp;T Inc. (18 items)">AT&amp;T Inc.</a> <a href="https://newsheater.com/tag/carnival-corporation-plc/" class="tag-cloud-link tag-link-2260 tag-link-position-2" style="font-size: 14.603773584906pt;" aria-label="Carnival Corporation &amp; Plc (31 items)">Carnival Corporation &amp; Plc</a> <a href="https://newsheater.com/tag/discovery-inc/" class="tag-cloud-link tag-link-6428 tag-link-position-3" style="font-size: 13.283018867925pt;" aria-label="Discovery Inc. (28 items)">Discovery Inc.</a> <a href="https://newsheater.com/tag/exxon-mobil-corporation/" class="tag-cloud-link tag-link-371 tag-link-position-4" style="font-size: 8.5283018867925pt;" aria-label="Exxon Mobil Corporation (18 items)">Exxon Mobil Corporation</a> <a href="https://newsheater.com/tag/f/" class="tag-cloud-link tag-link-331 tag-link-position-5" style="font-size: 8.5283018867925pt;" aria-label="F (18 items)">F</a> <a href="https://newsheater.com/tag/fcx/" class="tag-cloud-link tag-link-1206 tag-link-position-6" style="font-size: 8.5283018867925pt;" aria-label="FCX (18 items)">FCX</a> <a href="https://newsheater.com/tag/ford-motor-company/" class="tag-cloud-link tag-link-333 tag-link-position-7" style="font-size: 8.5283018867925pt;" aria-label="Ford Motor Company (18 items)">Ford Motor Company</a> <a href="https://newsheater.com/tag/fox-corporation/" class="tag-cloud-link tag-link-1115 tag-link-position-8" style="font-size: 11.169811320755pt;" aria-label="Fox Corporation (23 items)">Fox Corporation</a> <a href="https://newsheater.com/tag/f-stock/" class="tag-cloud-link tag-link-332 tag-link-position-9" style="font-size: 8.5283018867925pt;" aria-label="F stock (18 items)">F stock</a> <a href="https://newsheater.com/tag/general-motors-company/" class="tag-cloud-link tag-link-179 tag-link-position-10" style="font-size: 8pt;" aria-label="General Motors Company (17 items)">General Motors Company</a> <a href="https://newsheater.com/tag/gm/" class="tag-cloud-link tag-link-180 tag-link-position-11" style="font-size: 8pt;" aria-label="GM (17 items)">GM</a> <a href="https://newsheater.com/tag/gm-stock/" class="tag-cloud-link tag-link-181 tag-link-position-12" style="font-size: 8pt;" aria-label="GM stock (17 items)">GM stock</a> <a href="https://newsheater.com/tag/inc-2/" class="tag-cloud-link tag-link-84 tag-link-position-13" style="font-size: 22pt;" aria-label="Inc (60 items)">Inc</a> <a href="https://newsheater.com/tag/jpm/" class="tag-cloud-link tag-link-1787 tag-link-position-14" style="font-size: 8.5283018867925pt;" aria-label="JPM (18 items)">JPM</a> <a href="https://newsheater.com/tag/jpmorgan-chase-co/" class="tag-cloud-link tag-link-1789 tag-link-position-15" style="font-size: 8.5283018867925pt;" aria-label="JPMorgan Chase &amp; Co. (18 items)">JPMorgan Chase &amp; Co.</a> <a href="https://newsheater.com/tag/jpm-stock/" class="tag-cloud-link tag-link-1788 tag-link-position-16" style="font-size: 8.5283018867925pt;" aria-label="JPM stock (18 items)">JPM stock</a> <a href="https://newsheater.com/tag/moderna-inc/" class="tag-cloud-link tag-link-6802 tag-link-position-17" style="font-size: 9.0566037735849pt;" aria-label="Moderna Inc. (19 items)">Moderna Inc.</a> <a href="https://newsheater.com/tag/morgan-stanley/" class="tag-cloud-link tag-link-151 tag-link-position-18" style="font-size: 8pt;" aria-label="Morgan Stanley (17 items)">Morgan Stanley</a> <a href="https://newsheater.com/tag/mrna/" class="tag-cloud-link tag-link-4228 tag-link-position-19" style="font-size: 8.5283018867925pt;" aria-label="MRNA (18 items)">MRNA</a> <a href="https://newsheater.com/tag/mrna-stock/" class="tag-cloud-link tag-link-4229 tag-link-position-20" style="font-size: 10.11320754717pt;" aria-label="MRNA stock (21 items)">MRNA stock</a> <a href="https://newsheater.com/tag/ms/" class="tag-cloud-link tag-link-152 tag-link-position-21" style="font-size: 8pt;" aria-label="MS (17 items)">MS</a> <a href="https://newsheater.com/tag/ms-stock/" class="tag-cloud-link tag-link-153 tag-link-position-22" style="font-size: 8pt;" aria-label="MS stock (17 items)">MS stock</a> <a href="https://newsheater.com/tag/nasdaqmrna/" class="tag-cloud-link tag-link-4230 tag-link-position-23" style="font-size: 8.5283018867925pt;" aria-label="NASDAQ:MRNA (18 items)">NASDAQ:MRNA</a> <a href="https://newsheater.com/tag/nysef/" class="tag-cloud-link tag-link-334 tag-link-position-24" style="font-size: 8.5283018867925pt;" aria-label="NYSE:F (18 items)">NYSE:F</a> <a href="https://newsheater.com/tag/nysegm/" class="tag-cloud-link tag-link-182 tag-link-position-25" style="font-size: 8pt;" aria-label="NYSE:GM (17 items)">NYSE:GM</a> <a href="https://newsheater.com/tag/nysejpm/" class="tag-cloud-link tag-link-1790 tag-link-position-26" style="font-size: 8.5283018867925pt;" aria-label="NYSE:JPM (18 items)">NYSE:JPM</a> <a href="https://newsheater.com/tag/nysems/" class="tag-cloud-link tag-link-154 tag-link-position-27" style="font-size: 8pt;" aria-label="NYSE:MS (17 items)">NYSE:MS</a> <a href="https://newsheater.com/tag/nyseslb/" class="tag-cloud-link tag-link-99 tag-link-position-28" style="font-size: 8pt;" aria-label="NYSE:SLB (17 items)">NYSE:SLB</a> <a href="https://newsheater.com/tag/nyset/" class="tag-cloud-link tag-link-1330 tag-link-position-29" style="font-size: 8.5283018867925pt;" aria-label="NYSE:T (18 items)">NYSE:T</a> <a href="https://newsheater.com/tag/nysewfc/" class="tag-cloud-link tag-link-454 tag-link-position-30" style="font-size: 8.5283018867925pt;" aria-label="NYSE:WFC (18 items)">NYSE:WFC</a> <a href="https://newsheater.com/tag/nysexom/" class="tag-cloud-link tag-link-372 tag-link-position-31" style="font-size: 8.5283018867925pt;" aria-label="NYSE:XOM (18 items)">NYSE:XOM</a> <a href="https://newsheater.com/tag/pfe-stock/" class="tag-cloud-link tag-link-1813 tag-link-position-32" style="font-size: 9.0566037735849pt;" aria-label="PFE stock (19 items)">PFE stock</a> <a href="https://newsheater.com/tag/slb/" class="tag-cloud-link tag-link-38 tag-link-position-33" style="font-size: 8pt;" aria-label="SLB (17 items)">SLB</a> <a href="https://newsheater.com/tag/slb-stock/" class="tag-cloud-link tag-link-101 tag-link-position-34" style="font-size: 8pt;" aria-label="SLB stock (17 items)">SLB stock</a> <a href="https://newsheater.com/tag/t/" class="tag-cloud-link tag-link-1331 tag-link-position-35" style="font-size: 8.5283018867925pt;" aria-label="T (18 items)">T</a> <a href="https://newsheater.com/tag/tesla-inc/" class="tag-cloud-link tag-link-6768 tag-link-position-36" style="font-size: 8.5283018867925pt;" aria-label="Tesla Inc (18 items)">Tesla Inc</a> <a href="https://newsheater.com/tag/t-stock/" class="tag-cloud-link tag-link-1332 tag-link-position-37" style="font-size: 8.5283018867925pt;" aria-label="T stock (18 items)">T stock</a> <a href="https://newsheater.com/tag/uber/" class="tag-cloud-link tag-link-1262 tag-link-position-38" style="font-size: 8.5283018867925pt;" aria-label="UBER (18 items)">UBER</a> <a href="https://newsheater.com/tag/under-armour-inc/" class="tag-cloud-link tag-link-6314 tag-link-position-39" style="font-size: 13.811320754717pt;" aria-label="Under Armour Inc. (29 items)">Under Armour Inc.</a> <a href="https://newsheater.com/tag/wfc/" class="tag-cloud-link tag-link-456 tag-link-position-40" style="font-size: 8.5283018867925pt;" aria-label="WFC (18 items)">WFC</a> <a href="https://newsheater.com/tag/wfc-stock/" class="tag-cloud-link tag-link-457 tag-link-position-41" style="font-size: 8.5283018867925pt;" aria-label="WFC stock (18 items)">WFC stock</a> <a href="https://newsheater.com/tag/wti/" class="tag-cloud-link tag-link-3254 tag-link-position-42" style="font-size: 10.11320754717pt;" aria-label="WTI (21 items)">WTI</a> <a href="https://newsheater.com/tag/xom/" class="tag-cloud-link tag-link-373 tag-link-position-43" style="font-size: 8.5283018867925pt;" aria-label="XOM (18 items)">XOM</a> <a href="https://newsheater.com/tag/xom-stock/" class="tag-cloud-link tag-link-374 tag-link-position-44" style="font-size: 8.5283018867925pt;" aria-label="XOM stock (18 items)">XOM stock</a> <a href="https://newsheater.com/tag/zillow-group-inc/" class="tag-cloud-link tag-link-6682 tag-link-position-45" style="font-size: 9.5849056603774pt;" aria-label="Zillow Group Inc. (20 items)">Zillow Group Inc.</a></div></div></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-3"><div class="jeg_wrapper wpb_wrapper"><div class="jeg_footer_heading jeg_alignleft jnews_module_238879_4_5ffd69e20ba3e "><h3 class="jeg_footer_title" >Newsletter</h3></div><div class="wpb_text_column wpb_content_element " ><div class="wpb_wrapper"><p>Coming Soon</p></div></div></div></div><div class="jeg_aligncenter wpb_column jeg_column vc_column_container vc_col-sm-12"><div class="jeg_wrapper wpb_wrapper"><div class="vc_empty_space" style="height: 30px"><span class="vc_empty_space_inner"></span></div><div class="vc_separator wpb_content_element vc_separator_align_center vc_sep_width_100 vc_sep_pos_align_center vc_separator_no_text" ><span class="vc_sep_holder vc_sep_holder_l"><span style="border-color:rgb(255,255,255);border-color:rgba(255,255,255,0.15);" class="vc_sep_line"></span></span><span class="vc_sep_holder vc_sep_holder_r"><span style="border-color:rgb(255,255,255);border-color:rgba(255,255,255,0.15);" class="vc_sep_line"></span></span></div><div class='jnews_module_238879_5_5ffd69e20bf35'><ul class="jeg_menu_footer"><li id="menu-item-236568" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236568"><a href="https://newsheater.com/home/">Home</a></li><li id="menu-item-236570" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236570"><a href="https://newsheater.com/about-newsheater/">About Newsheater</a></li><li id="menu-item-236569" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236569"><a href="https://newsheater.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-236571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236571"><a href="https://newsheater.com/contact-us/">Contact Us</a></li></ul></div><div class="wpb_text_column wpb_content_element vc_custom_1610224066737 copyright" ><div class="wpb_wrapper"><p>© 2021 Newsheater</p></div></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div></p></div></div></div></div></div><div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand rounded"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://newsheater.com/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult"> No Result</div><div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result</div></div></div><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li id="menu-item-81" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-81"><a href="https://newsheater.com/">Homepages</a></li><li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://newsheater.com/category/business/">Business</a></li></ul></div></div><div class="item_bottom"><div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/jegtheme/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/jegtheme" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://plus.google.com/+Jegtheme" target='_blank' class="jeg_google-plus removed"><i class="fa fa-google-plus"></i> </a><a href="https://www.linkedin.com/" target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© 2020 Newsheater.com</p></div></div></div></div></div><script type="text/javascript">var jfla = ["view_counter"]</script><div class="cpro-onload cp-popup-global cp-custom-cls-manual_trigger_236629 " data-class-id="236629" data-inactive-time='60' ></div><div id="cp_popup_id_236629" class="cp-popup-container cp-popup-live-wrap cp_style_236629 cp-module-modal_popup " data-style="cp_style_236629" data-module-type="modal_popup" data-class-id="236629" data-styleslug="co-reg"><div class="cpro-overlay"><div class="cp-popup-wrapper cp-auto " ><div class="cp-popup cpro-animate-container "><form class="cpro-form" method="post"> <input type='hidden' class='panel-settings' data-style_id= '236629' data-section='configure' value='{&quot;enable_custom_cookies&quot;:&quot;&quot;,&quot;enable_cookies_class&quot;:&quot;&quot;,&quot;enable_adblock_detection&quot;:&quot;1&quot;,&quot;enable_visitors&quot;:&quot;&quot;,&quot;visitor_type&quot;:&quot;first-time&quot;,&quot;referrer_type&quot;:&quot;hide-from&quot;,&quot;hide_custom_cookies&quot;:&quot;&quot;,&quot;hide_cookies_class&quot;:&quot;&quot;,&quot;show_for_logged_in&quot;:&quot;1&quot;,&quot;hide_on_device&quot;:&quot;&quot;,&quot;cookies_enabled&quot;:&quot;1&quot;,&quot;conversion_cookie&quot;:&quot;90&quot;,&quot;closed_cookie&quot;:&quot;1&quot;,&quot;cookies_enabled_submit&quot;:&quot;1&quot;,&quot;enable_cookies_class_submit&quot;:&quot;&quot;,&quot;conversion_cookie_submit&quot;:&quot;90&quot;,&quot;cookies_enabled_closed&quot;:&quot;0&quot;,&quot;enable_cookies_class_closed&quot;:&quot;&quot;,&quot;closed_cookie_new&quot;:&quot;30&quot;}' ><input type='hidden' class='panel-rulesets' data-style_id= '236629' data-section='configure' value='[{&quot;name&quot;:&quot;Ruleset 1&quot;,&quot;autoload_on_duration&quot;:true,&quot;load_on_duration&quot;:&quot;15&quot;,&quot;modal_exit_intent&quot;:&quot;1&quot;,&quot;autoload_on_scroll&quot;:false,&quot;load_after_scroll&quot;:75,&quot;inactivity&quot;:false,&quot;inactivity_link&quot;:&quot;&quot;,&quot;enable_after_post&quot;:false,&quot;enable_custom_scroll&quot;:false,&quot;enable_scroll_class&quot;:&quot;&quot;,&quot;on_scroll_txt&quot;:&quot;&quot;,&quot;show_cta_info&quot;:&quot;&quot;,&quot;enable_custom_cookies&quot;:false,&quot;enable_cookies_class&quot;:&quot;&quot;,&quot;on_cookie_txt&quot;:&quot;&quot;,&quot;hide_cta_link&quot;:&quot;&quot;,&quot;enable_adblock_detection&quot;:&quot;1&quot;,&quot;all_visitor_info&quot;:&quot;&quot;,&quot;enable_visitors&quot;:&quot;&quot;,&quot;visitor_type&quot;:&quot;first-time&quot;,&quot;enable_referrer&quot;:&quot;&quot;,&quot;referrer_type&quot;:&quot;hide-from&quot;,&quot;display_to&quot;:&quot;&quot;,&quot;hide_from&quot;:&quot;&quot;,&quot;enable_scheduler&quot;:false,&quot;enable_scheduler_txt&quot;:&quot;&quot;,&quot;start_date&quot;:&quot;&quot;,&quot;end_date&quot;:&quot;&quot;,&quot;custom_cls_text_head&quot;:&quot;&quot;,&quot;enable_custom_class&quot;:&quot;1&quot;,&quot;copy_link_code_button&quot;:&quot;Copy Link Code&quot;,&quot;copy_link_cls_code_button&quot;:&quot;&quot;,&quot;custom_class&quot;:&quot;&quot;,&quot;custom_cls_text&quot;:&quot;&quot;}]' ><style id='cp_popup_style_236629' type='text/css'>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</style><div class="cp-popup-content cpro-active-step cp-modal_popup cp-panel-1" data-entry-animation = "cp-fadeIn" data-overlay-click ="1" data-title="Co Reg" data-module-type="modal_popup" data-step="1" data-width="800" data-mobile-width="320" data-height="500" data-mobile-height="200" data-mobile-break-pt="767" data-mobile-responsive="yes"><div class="cpro-form-container"><div id="cp_heading-1-236629" class="cp-field-html-data cp-none cp_has_editor" data-type="cp_heading" ><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-heading tinymce" name="cp_heading-1"><p>Get The Best Stocks To Trade Every Day!</p></div></div></div><div id="cp_sub_heading-1-236629" class="cp-field-html-data cp-none cp_has_editor" data-type="cp_sub_heading" data-field-title="Subheading" ><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-sub-heading tinymce" name="{{name}}"><p>Join now to get the NewsHeater.com pre-market morning brief 100% free</p></div></div></div><div id="cp_close_image-1-236629" class="cp-field-html-data cp-none cp-image-ratio cp-close-field cp-close-image-wrap" data-type="cp_close_image" data-field-title="Close Image" data-action="close" ><div class="cp-rotate-wrap"><div class="cp-image-main"><img data-cp-src="https://newsheater.com/wp-content/plugins/convertpro/assets/admin/img/close1.png" class="cp-target cp-field-element cp-close-image cp-img-lazy" alt="" name="cp_close_image-1" value="" src=""><div class="cp-field-shadow"></div></div></div></div><div id="cp_email-1-236629" class="cp-field-html-data cp-none" data-type="cp_email" > <input type="email" class="cp-target cp-field-element cp-form-input-field cp-form-field cp-email cp-form-field cp-email-field" aria-label="Enter your email here" placeholder="Enter your email here" name="param[email]" value="" required="required" data-email-error-msg="{{email-error}}" autocomplete="on" /></div><div id="cp_paragraph-1-236629" class="cp-field-html-data cp-none cp_has_editor" data-type="cp_paragraph" data-field-title="Paragraph" ><div class="cp-rotate-wrap"><div class="cp-target cp-field-element cp-paragraph tinymce" name="{{name}}"><p>We do not sell or share your information with anyone.</p></div></div></div><div id="cp_button-1-236629" class="cp-field-html-data cp-none" data-type="cp_button" data-action="submit_n_goto_url" data-step="1" data-redirect="https://offers.afteroffers.com/show_offers/568-RiAQXxc-1" data-redirect-target="_self" ><div class="cp-rotate-wrap"><button type="submit" class=" cp-target cp-field-element cp-button cp-button-field" data-success-message="Thank You for Subscribing!" data-get-param="true">Yes, Sign Me Up!</button><div class="cp-btn-tooltip"></div></div></div><div id="cp_image-2-236629" class="cp-field-html-data cp-none cp-image-ratio" data-type="cp_image" data-action="none" data-step="1" ><div class="cp-rotate-wrap"><div class="cp-image-main"><img data-cp-src="//newsheater.com/wp-content/uploads/convertpro/design_918/2.jpg" class="cp-img-lazy cp-target cp-field-element cp-image" name="cp_image-2" alt="236632" src=""><div class="cp-field-shadow"></div></div></div></div><div id="cp_image-1-236629" class="cp-field-html-data cp-none cp-image-ratio" data-type="cp_image" data-action="none" data-step="1" ><div class="cp-rotate-wrap"><div class="cp-image-main"><img data-cp-src="//newsheater.com/wp-content/uploads/convertpro/design_918/3.jpg" class="cp-img-lazy cp-target cp-field-element cp-image" name="cp_image-1" alt="236633" src=""><div class="cp-field-shadow"></div></div></div></div><div id="cp_image-3-236629" class="cp-field-html-data cp-none cp-image-ratio" data-type="cp_image" data-action="none" data-step="1" ><div class="cp-rotate-wrap"><div class="cp-image-main"><img data-cp-src="//newsheater.com/wp-content/uploads/convertpro/design_918/4.jpg" class="cp-img-lazy cp-target cp-field-element cp-image" name="cp_image-3" alt="236634" src=""><div class="cp-field-shadow"></div></div></div></div><div id="cp_google_recaptcha-1-236629" class="cp-field-html-data {{animation}} cp-hidden-input-field cp-google-recaptcha-field" data-type="cp_google_recaptcha" data-field-title="Recaptcha" > <input type="hidden" class="cp-target cp-field-element cp-form-field cp-google-recaptcha " name="cp_google_recaptcha_verify" value="6Le5p-wZAAAAAJBkLos0NwgF_c4awNNUoP83TWLP" placeholder="recaptcha field" /> <span class="recaptcha-msg-error error"></span><div class="g-recaptcha" data-sitekey= "6Le5p-wZAAAAAJBkLos0NwgF_c4awNNUoP83TWLP"></div></div></div></div> <input type="hidden" name="param[date]" value="January 12, 2021" /> <input type='text' class='cpro-hp-field' name='cpro_hp_field_236629' value=''> <input type="hidden" name="action" value="cp_v2_add_subscriber" /> <input type="hidden" name="style_id" value="236629" /></form></div></div></div></div><div id="selectShareContainer"><div class="selectShare-inner"><div class="select_share jeg_share_button"> <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" data-image-url="" data-title="Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fnewsheater.com%2F2021%2F01%2Fis-hecla-mining-company-hl-a-keeper%2F" data-image-url="" data-title="Is+Hecla+Mining+Company+%28HL%29+a+Keeper%3F+via+%40jegtheme" ><i class="fa fa-twitter"></i></a></div><div class="selectShare-arrowClip"><div class="selectShare-arrow"></div></div></div></div><div class="jeg_read_progress_wrapper"></div><script type="text/html" id="wpb-modifications"></script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/comment-reply.min.js?ver=5.6' id='comment-reply-js' defer></script> <script   type='text/javascript' id='mediaelement-core-js-before'>var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};</script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.6' id='mediaelement-migrate-js' defer></script> <script type='text/javascript' id='mediaelement-js-extra'>/* <![CDATA[ */ var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"}; /* ]]> */</script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.6' id='wp-mediaelement-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=6.4.2' id='isotope-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/lazysizes-712c1558f5185c54777f7cab0c8f1887.js' id='lazysizes-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/ls.bgset-734a3691414f75eb8865d647ddec4a81.js' id='bgset-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/owl-carousel2/owl.carousel-61cfff01d8930de3c0c7694334f462c5.js' id='owlcarousel-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/superfish-35086e4efca5d38fb30d361b89bf5436.js' id='superfish-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/theia-sticky-sidebar-c348dcb00b9825bc17d83c95f03d39b0.js' id='theia-sticky-sidebar-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.waypoints-51d4574d6e93c05ed3fe41536cb3c6ba.js' id='waypoint-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.scrollTo-a5e36e1710e0258580eaa3f95dffd6e3.js' id='scrollto-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.parallax-4cd3321f8648c41779638065b4730638.js' id='parallax-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.okayNav-fe04a92294a3ab7f6b8a02a9f911afba.js' id='okaynav-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.mousewheel-9a9eaf72f41fb900672bd5bb39a6bb3e.js' id='mousewheel-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/modernizr-custom-4644aca994e0c84a484067f76bdc4fd0.js' id='modernizr-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.smartresize-dee61fa607de4d13666e1eded48d68d5.js' id='smartresize-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/chosen.jquery-b0902912fe2c664fe1ebc00019e8fd23.js' id='chosen-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.magnific-popup-7cda4ddb953104c34b2e4c1049829904.js' id='magnific-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jnewsgif-ed74d018c0a78865a41c9f9720e6aee3.js' id='jnews-gif-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jowlslider-74a97a839c4bf99ea9054cb8c8f45492.js' id='jnews-owlslider-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.jsticky-d1ee3fb02eef560bc343dcec2f1ba24f.js' id='jnews-sticky-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-content/themes/jnews/assets/js/jquery.transit.min.js?ver=7.1.8' id='jquery-transit-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/jquery.module-4ef91dd39543c619e685cb124ee2fc06.js' id='jnews-landing-module-js' defer></script> <script type='text/javascript' id='jnews-main-js-extra'>/* <![CDATA[ */ var jnewsoption = {"login_reload":"https:\/\/newsheater.com\/2021\/01\/is-hecla-mining-company-hl-a-keeper","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"238879","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"newsheater.com","zoom_button":"0"}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/main-41fff5179754e155faf2c4a5df0fc5e5.js' id='jnews-main-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/zoom-button-a1dfb73d351831505e2bb3f9866b96af.js' id='jnews-zoom-button-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/popup-post-753a8aaa39839c704fe6795f8f0e8649.js' id='jnews-popup-post-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/themes/jnews/assets/js/darkmode-12773d1cdecd909d7563b01779c71ed6.js' id='jnews-darkmode-js' defer></script> <!--[if lt IE 9]>
<script data-wpacu-script-handle='html5shiv' type='text/javascript' src='https://newsheater.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=7.1.8' id='html5shiv-js'></script>
<![endif]--> <script type='text/javascript' id='jnews-select-share-js-extra'>/* <![CDATA[ */ var jnews_select_share = {"is_customize_preview":""}; /* ]]> */</script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/plugins/jnews-social-share/assets/js/plugin-a61fd45727a2593edab9974b14392e8e.js' id='jnews-select-share-js' defer></script> <script data-minify="1"   type='text/javascript' src='https://newsheater.com/wp-content/cache/min/1/wp-content/plugins/jnews-weather/assets/js/plugin-3519150a8b9608f5527b9ddccc9f1c8d.js' id='jnews-weather-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.4.2' id='wpb_composer_front_js-js' defer></script> <script   type='text/javascript' src='https://newsheater.com/wp-content/plugins/js_composer/assets/lib/bower/skrollr/dist/skrollr.min.js?ver=6.4.2' id='vc_jquery_skrollr_js-js' defer></script> <script type='text/javascript' id='cp-popup-script-js-extra'>/* <![CDATA[ */ var cp_ajax = {"url":"https:\/\/newsheater.com\/wp-admin\/admin-ajax.php","ajax_nonce":"64034749ad","assets_url":"https:\/\/newsheater.com\/wp-content\/plugins\/convertpro\/assets\/","not_connected_to_mailer":"This form is not connected with any mailer service! Please contact web administrator.","timer_labels":"Years,Months,Weeks,Days,Hours,Minutes,Seconds","timer_labels_singular":"Year,Month,Week,Day,Hour,Minute,Second","image_on_ready":"","cpro_mx_valid":"1","invalid_email_id":"Invalid Email Address!"};
var cp_pro = {"inactive_time":"60"};
var cp_pro_url_cookie = {"days":"30"};
var cp_ga_object = {"ga_auth_type":"universal-ga","ga_category_name":"Convert Pro","ga_event_name":"CONVERTPRO","ga_anonymous_ip":"checked"};
var cp_v2_ab_tests = {"cp_v2_ab_tests_object":[]}; /* ]]> */</script> <script   type='text/javascript' defer="defer" src='https://newsheater.com/wp-content/plugins/convertpro/assets/modules/js/cp-popup.min.js?ver=1.5.5' id='cp-popup-script-js'></script> <script   type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=1.5.5' id='cp-google-recaptcha-js'></script> <script type="text/javascript">jQuery(document).on( "cp_after_form_submit", function( e, element, response
					, style_slug ) {

					if( false == response.data.error ) {

						if( 'undefined' !== typeof response.data['cfox_data']  ) {
							var form_data = JSON.parse( response.data['cfox_data']  );

							form_data.overwrite_tags = false;

							if( 'undefined' !== typeof convertfox ) {
								convertfox.identify( form_data );
							}
						}
					}

				});</script> <div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Is Hecla Mining Company (HL) a Keeper?","published":"2021-01-11 10:12:00","updated":"2021-01-11 10:12:00"}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/newsheater.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/newsheater.com\/category\/trending\/","name":"Trending"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/newsheater.com","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/newsheater.com\/category\/trending\/","name":"Trending"}}]}</script>  <script type="text/javascript">!function(e){var t="";e(window).on("cp_after_popup_open",function(e,t,n,o){var a=jQuery('.cp-popup-container[data-style="cp_style_'+o+'"]').data("styleslug");cpUpdateImpressions(a)}),cpUpdateImpressions=function(e){var t=cp_ga_object.ga_category_name;cpCreateGoogleAnalyticEvent(t,"impression",e)},cpIsModuleOnScreen=function(e){var t=jQuery(window),n={top:t.scrollTop(),left:t.scrollLeft()};n.right=n.left+t.width(),n.bottom=n.top+t.height();var o=e.offset();return o.right=o.left+e.outerWidth(),o.bottom=o.top+e.outerHeight(),!(n.right<o.left||n.left>o.right||n.bottom<o.top||n.top>o.bottom)},e(document).on("cp_after_form_submit",function(e,t,n,o){if(!0===n.success){var a=cp_ga_object.ga_category_name;cpCreateGoogleAnalyticEvent(a,"conversion",o)}}),cpCreateGoogleAnalyticEvent=function(e,n,o){void 0!==t&&("undefined"!=typeof ga?t=ga:"undefined"!=typeof _gaq?t=_gaq:"function"==typeof __gaTracker?t=__gaTracker:"function"==typeof gaplusu&&(t=gaplusu));var a=void 0!==cp_ga_object.ga_auth_type?cp_ga_object.ga_auth_type:"universal-ga";"undefined"!=typeof dataLayer&&"gtm-code"==a?dataLayer.push({event:cp_ga_object.ga_event_name,eventCategory:e,eventAction:n,eventLabel:o,eventValue:"1",nonInteraction:!0}):"gtag"==a&&"undefined"!=typeof gtag?"unchecked"!=cp_ga_object.ga_anonymous_ip?gtag("event",n,{event_label:o,event_category:e,non_interaction:!0,anonymize_ip:!0}):gtag("event",n,{event_label:o,event_category:e,non_interaction:!0}):"universal-ga"!=a&&"manual"!=a||"function"!=typeof t||("unchecked"!=cp_ga_object.ga_anonymous_ip?t("send","event",e,n,o,{nonInteraction:!0,anonymizeIp:!0}):t("send","event",e,n,o,{nonInteraction:!0}))},cp_track_inline_modules=function(){jQuery(".cp-popup-container.cp-module-before_after, .cp-popup-container.cp-module-inline, .cp-popup-container.cp-module-widget").each(function(){var e=jQuery(this);e.data("style").replace("cp_style_","");if(cpIsModuleOnScreen(e)&&!e.hasClass("cp-impression-counted")){var t=e.data("styleslug");cpUpdateImpressions(t),e.addClass("cp-impression-counted")}})},e(document).ready(function(){cp_track_inline_modules()}),e(document).scroll(function(e){cp_track_inline_modules()})}(jQuery);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://newsheater.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1610443234 -->